Setup a Cisco Router with POTS on Amnet ADSL

I recently posted a Cisco config on a bridge mode ADSL2+ modem.  Well as I’m a IT Consultant, I get my hands on a fair bit of hardware.  Well this weekend I’ve had a unit that needed testing, as it was failing to transfer data across it’s ADSL link.  Fortunately for me it wasn’t faulty, so I’ve managed to get a working config.

Lanchbury Cisco Layout on Temperary 800 Series Router

This is the more regular setup of a Cisco router, so if your looking for a config for a Amnet connection try the below.  Copy the below text into notepad, edit the {brackets} and then paste it into a Cisco’s Configure Terminal prompt.

no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname {router-name}
!
boot-start-marker
boot-end-marker
!
enable secret {enable-password}
!
no aaa new-model
!
!
!
!
ip cef
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
ip domain lookup source-interface Dialer0
ip domain name {local-domain-name}
ip name-server {local-dns-server or 203.161.127.1 and/or 203.153.224.42}
!
vpdn enable
!
vpdn-group pppoe
l2tp tunnel receive-window 128
!
!
!
username {username} privilege 15 secret {user-password}
!
!
archive
log config
hidekeys
!
!
!
!
!
interface ATM0
no ip address
no atm ilmi-keepalive
dsl operating-mode adsl2+
no shutdown
!
interface ATM0.1 point-to-point
description PPPOE WAN Interface
pvc 8/35
pppoe-client dial-pool-number 1
!
!
interface FastEthernet0
description Connected to Switch
no shutdown
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Dot11Radio0
no ip address
shutdown
speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
station-role root
!
interface Vlan1
ip address 172.17.2.1 255.255.255.0
ip nat inside
ip virtual-reassembly
!
interface Dialer0
ip address negotiated
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication chap callin
ppp chap hostname {amnet-username}@amnet
ppp chap password {amnet-password}
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer0
!
no ip http server
no ip http secure-server
ip nat inside source list 1 interface Dialer0 overload
ip nat inside source static tcp 172.17.2.{host} 80 interface Dialer0 80
ip nat inside source static tcp 172.17.2.{host} 443 interface Dialer0 443
{add in any more port forwards you want applied here with the above syntax}
!
access-list 1 permit 172.17.2.0 0.0.0.255
!
control-plane
!
banner motd ^CCC
**************************************************
* Access to authorized personnel only *
**************************************************^C
!
line con 0
exec-timeout 30 0
password {console-password}
logging synchronous
login
no modem enable
line aux 0
line vty 0 4
exec-timeout 30 0
password {remote-password}
logging synchronous
login local
transport input ssh
!
scheduler max-task-time 5000
end

2 comments

  1. I should probably mention (as I did in the previous comments on the other nonPOTS config) I have a DHCP server in my network, so this config doesn’t include it. If you do want it add the below.

    ip subnet-zero
    ip dhcp excluded-address 172.17.2.0 172.17.2.50
    !
    ip dhcp pool dhcp
    network 172.17.2.0 255.255.255.0
    domain-name amnet.net.au
    dns-server 203.161.127.1 203.153.224.41
    default-router 172.17.2.1

  2. I have found my connection a bit random on a Cisco router that I’ve purchase as my on. As such I’ve made the following changes that have made it look more stable.

    interface ATM0
    dsl operating-mode adsl2+
    !
    interface Dialer0
    no ip mtu 1492

    These have been changed in my original post.

Leave a Reply to Nathan Cancel reply

Your email address will not be published.

This site uses Akismet to reduce spam. Learn how your comment data is processed.